Printing Issue
Incident Report for DiscoverIT @ Discovery Building
Resolved
The printing issue has been resolved. Some jobs may need to be reprinted.
Posted Feb 08, 2024 - 09:56 CST
Investigating
The printers are currently failing to properly retrieve print jobs from the server. You can still send jobs to the print queue, but retrieving them at the printers is unavailable until the issue is resolved.
Posted Feb 08, 2024 - 09:44 CST
This incident affected: Help Desk (Printing and Scanning).